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HANDY EXCEL SHORTCUTS 
 

Use Handy Excel Shortcuts.xlsx to try them out 

File 
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Navigation 
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Extended Selection 
 

 

 

 

 

Workbooks 
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PIVOT-TABLES 
 

Whenever I say “table” I mean the raw data in the spreadsheet. Pivot-Table is created out of the raw 

data “table”. 

Open the excel workbook “Pivot Tables.xlsx” 

Go to Worksheet “Data” 

 

There is a table: With 8 columns. The columns are called FIELDS 

Have a look at the columns and make sense of them... 

The following figure is the Ribbon. It is the menu at the top of the Excel interface 

 

Figure 1 The Ribbon 

To create a Pivot-Table: 

1. Click anywhere within the table 

2. Go to the Ribbon -> Insert -> PivotTable 

3. Observe and verify that Excel is considering the correct data, check the columns and the final row 

4. Choose where to place the Pivot-Table: (select New Worksheet) 

MAKE SURE: 

1. that ALL columns have a LABEL, i.e. a NAME.  

2. There is no empty row between the table and any other data around it 
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FIX WHATEVER IS NEEDED because there IS a blank row at Row 555 

 

Rename the new worksheet as: PivotTable 

Click anywhere in the Pivot Table are for the PivotTable Field List to appear 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you click somewhere outside the Pivot table area, then the Filed list disappears.. Click again inside the 

PT area and the filed list appears.  

 

Notice the list of all the columns you have (FIELDS) and four (4) boxes below, in the PivotTable field list 

from the PivotTable Fields… 

1. Drag the Salesperson to the Row Labels box 

2. Drag the Customer to the Column Labels box 

3. Drag the No.Items in the Values box 

 

What do you see here? 

Total # of items each Salesperson sold to each Customer. 

Figure 3 Pivot Table area 

Figure 2 FIELD list 
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Watch the grand totals (ROW and COLUMN totals) 

4. Sort the data 

 According to what Customer? 

 Right Click on any value of Fabulous Homes 

 Sort -> Largest to smallest 

 Who is the high selling salesperson?  

 

Question? Which customer do each Salesperson sells the most? Percentage-wise? 

5. Change to calculation to % of Row Total 

Click anywhere in the PivotTable (where the values are) and right-click 

Show Values as -> % of Row Total 

6. Change to calculation to % of Column Total 

 

You can also have both the actual number and the Row percentage in the Pivot Table 

6.1. Drag the No.Items (from the field list) and place it again in the Values box.  

You will see No.Items2 in the box.  

6.1. Pick one and change the calculation. So one field will be for % one with absolute numbers (no 

calculation) 

 

 

 

Question? How much more sales -percentage wise- do all Salespersons do compared to Emily Leon? 
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First remove the second No.Items from the Values box that shows the %. You righ-click on any value of 

that field in the Pivot Table and select Remove. 

7. Show Values as -> % Difference From 

 The base field to be Salesperson, and select Leon, Emily 

You can also compare all Customers against a single customer 

8. Show Values as -> % Difference From 

 The base field to be Customers, and eg. select B&B Spaces 

9. Rank the Salespersons according to their sales 

  Show Values as -> Rank Smallest to Largest 

 

Figure 4 More Value Calculations 

REMOVE the Value Calculations and go back to the original data format 

10. Right-click in the data - > Show Values as -> No Calculation 

 

Summarise as AVERAGE number of sales 
 

11. Right-click in the data - > Summarise As-> Average 

Summarise as the number (count) of Sales, i.e. how many times they sold something to each customer. 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 12 of 111 

12. Right-click in the data - > Summarise As-> Count 

 

You can play around with Total Cost now 

13. Remove No.Items from the Values box and place the Total Cost 

 

Use the Report Filter box 
 

14. Drag Region in the Report Filter box 

 See that nothing yet changes… 

 

15. Go to the upper left corner of the Pivot Table where the Region – (All) is seen 

 Select from the dropdown the Region – NW 

You may select more than on region 

16. Click the dropdown at the Region tab (upper left corner ) and click on the Select Multiple Items 

17. Select the Northern areas (NW, NE) 

 Now you can see the report only for the Northern Part 

 

Use 2 or more Fields in the Row Labels box (or the Column Labels box) 
 

18. Drag Region out of the Report Filter box and take it in the Row Labels box and place it after the 

Salesperson filed. 
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See that now the sales amount for each salesperson is broken down by the two regions (WHY only 2?) 

You can see that salesperson Arnold, Cole does not usually sell in the NW part. only to the customer 

Captain Recliner.  

 

19. Take REGION back to the Report Filter and select all regions 

20. Put it back to the Row Labels box. Now you have all the regions visible 

 

Group by Date 
 

We also have the date field. To utilise this filed WE NEED TO MAKE SURE excel is reading the values as 

dates! 

Go back to the Data worksheet. Are the dates in the right-hand side of the column? If yes, then we are 

good. If not, call me  (just kidding..). We either talked about handling this issues or we will do in this 

workshop. 

 

Remove all Fields from the Pivot Table 

21. Drag Date into the Row box, and No.Items into the Values box 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 14 of 111 

 

 

22. Right click on the column of the dates and select Group 

  

 

23. Select Months 

You now have the total items sold, by Month 
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23. Do it again, and select either Years or Quarters and see what happens 

 

24. Do it again and select both Year and Quarter 

 

 

It would be great to see the subtotals for each year… 

25. Go to the Ribbon -where the PivotTable Tools section is... 

If you can’t see the PivotTable Tools section in the Ribbon, then click somewhere in the Pivot Table area. 

It will appear  

26. Go to Design -> Subtotals and select -> Show all Subtotals at the Bottom of Group 
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27. Drag the Region in the Row Labels box 

Hmm.. Too many rows.. 

28. Go to PivotTable Tool sin the Ribbon - > Design -> Report Layout - > Show in Tabular View 

 

 

28. Right-Click on the Date Column-> Expand/ Collapse - > Collapse Entire Field 
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You get this.. 

 

 

You can now Expand (or Collapse) a single Quarter at a time 

29. Drag Region in the Columns Labels box 

Now you can see how many items were sold in each Quarter in each Year and for each Product 

SLICERS 
Click anywhere in the Pivot Table 

30. Go to PivotTables Tools in the Ribbon - > Options -> Insert Slicer 

31. Select Region, Customer, Date 

You will see three small tables Region, Customer, Date  

 

You can see that there are no dates before 06/01/2014 or after 31/12/2015 

You can slice your report by each customer or by a specific quarter 

If you want to select 2 customers, click on the first and then hold Ctrl and click on another 

Play around… 
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Pivot CHARTS 
Now we can generate charts out of the Pivot Table 

Click anywhere in the Pivot Table area 

32. Go to the Ribbon -> Insert -> Column -> Select the first type of column chart 

 

 

To slice the data, you can use either the: 

a) Slicers you have just created 

b) The labels within the chart [the grey buttons), namely the Product, Year, Date, Region 

 

 

To change the layout of the graph first click on the graph go to the PivotChart Tools section  

33. Click on the chart and Go to PivotChart Tools-> Layout  

34. Select the Chart title -> Above chart 

Name the chart 
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35. Select the Data labels and select Outside End 

 

Play around… 
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CHARTS 
 

Use the workbook Charts.xlsx 

Create your first graph 
 

Use the worksheet Charts 

Here we have furniture sales by type (Rows) and by regions (Columns) 

1. Select the table  (leave the grand totals out) 

 

2. Go to Inset-> Column -> Clustered column 

 

You get this..  

 

This shows the number of sales in each region across the product 

Note that there are four (4)  “series” ; The 4 regions 
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The x-axis breaks down the sales by Product (across product) 

If you want the graph to show the number of sales of each product across the regions, then.. 

3. Click on the graph  

left click the mouse with the cursor anywhere on the chart, you will notice that the border thickness of 

the chart increases when it is selected, this is just Excels way of showing you that the object has been 

selected. 

4. Go to Chart Tools-> Design-> Switch Row/Column 

 

 

Now, the “Series” are the five (5) products and the sales are broken down (across) by the region 

To understand the series and the x-axis values… 

5. Go to Design (are you in the ChartTools section?)  

6. Click on the Select Data 

 

 

Switch Row/Column and see what happens 

 

 -
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Let’s add values to the bars 

(make sure the graph is selected) 

7. Go to Layout-> Data labels-> Inside End 

 

8. On the same section (Layout) Go to Axis titles 

Place an x-axis (horizontal) and a y-axis title (vertical) 

 

Note: There are some standard chart layouts available 

Try them out… 

 

Now, let’s see a different graph 

9. Go to Design-> Change Chart Type 

Select the Stacked Column 
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What does this graph tell you? What it is the difference between the previous one? 

 

 

Add a title 
 

10. Go to Layout-> Chart Title 

 

You can also use a cell reference for the title 

Change the scale of the graph 
11. Double click on the Y axis 

Make sure you see a rectangle around the Y-axis(as seen in the picture)  

The Format axis dialogue box will appear 
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You can see that all Axis options are in Auto 

For the maximum click the Fixed and set it to 4000 

You can also try..  Values in reverse order and see what happens 

 

 

Percentage charts 
 

We will explore the Row and Column percentages and make a graph 

First we will recreate the product names and region names 

12. Go to cell B12 and type  =B2 

Drag the cell to the right up to cell G12, and take the B12 cell and drag it down to B17  

We will calculate the proportion of product within each region. So we will divide the sales for each 

product over the total sales of the region 

13. In cell C13 type  

= C3/$C$8   (don’t forget to lock the C8 cell) 

.  
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14. Do the same for all regions 

..(or use mixed references) 

This is what you get 

 

 

15. Highlight the numbers and turn them into percentages by clinking on the button % at the ribbon at 

the Home section. Or right click and format cells as percentages 

 

 

 

 

Now let’s create a 100% stacked bar 

16. Go to Insert->Bar->100% stacked 

Product NE NW SE SW

Bamboo Coffee Table 0.196 0.223 0.377 0.157

Bamboo End Table 0.18 0.133 0.162 0.202

Captain Recliner 0.131 0.267 0.075 0.152

Chameleon Couch 0.284 0.153 0.173 0.27

Media Armoire 0.209 0.225 0.213 0.219

Product NE NW SE SW

Bamboo Coffee Table 20% 22% 38% 16%

Bamboo End Table 18% 13% 16% 20%

Captain Recliner 13% 27% 8% 15%

Chameleon Couch 28% 15% 17% 27%

Media Armoire 21% 22% 21% 22%
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Apply some formatting and insert y and x axes and insert a chart title 

 

This way you show the distribution of the items sold within each AREA but also compare this distribution 

among the areas 

  

20%

22%

38%

16%

18%

13%

16%

20%

13%

27%

8%

15%

28%

15%

17%

27%

21%

22%

21%

22%

0% 20% 40% 60% 80% 100%

NE

NW

SE

SW

Axis Title

A
R

EA

Chart Title

Bamboo Coffee Table Bamboo End Table

Captain Recliner Chameleon Couch



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 27 of 111 

Add a secondary Y-axis 
 

Use the worksheet Secondary 

 

We have No of items sold in each month and the associating income 

1. Select all three columns 

2. Go to Insert-Line-2D 

 

Units sold are in multiples of ten whereas the income is in multiples of thousands. As a result of this 

mismatch in data the Excel chart fails to fit the data correctly and it makes the number of units sold 

impossible to read, the line just looks flat at the bottom of the chart if you can see it! 

3. Select the red line (Income) and right-click 
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4. Select Format Data Series and press Close 

 

 

Now you have two Y axis.  

The Left Y-axis is for Items sold (see the scale 0 to 14) 

The Right Y-axis is for the Income (see the scale – 0 to 12000) 

 

NOW lets format it 

5. Click on the graph 

6. Go to ChartTools -> Layout 

 

 

7. Click on the Axis Titles -> Secondary Vertical Axis -> Vertical title 
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8. Change the vertical axis into INCOME 

9. DO the same now for the Primary Y axis 

10. Click on the outer border of the chart and resize the fonts 

 Go to HOME section and change the font 

11. Double click on the Legend and set the position to Top 

 

 

Save a chart as a Template 
You can save this formatting as a template 

12. Click on the graph 

13. Go to Design-> Save as Template 

14. Type a name.. eg. Secondary Axis  

 

15. Select the next table  
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16. Insert-> Column - > go down to All chart types 

17. Go to Templates and select the Secondary Axis 

18. Press OK 

 

YOU ARE GOOD TO GO. 

Change the axis labels etc. 

 

 

Combine Column and Line chart 
On the same worksheet 

19. Select A2:C14 (No.items and Income along with Month) 

20. Insert->Column->Clustered column 

Item Items  Total

Bath 5 15,594.42$         

Bedroom 12 58,318.15$         

Dining 13 45,819.35$         

Entryways 10 8,803.00$           

Kids Room 8 23,808.38$         

Kitchen 6 20,398.74$         

Living Room 8 49,507.94$         
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You can see two series (2 bar colours)  

21. Click on the red bars (Income) 

22. Go to ChartTools section in the Design and select Change chart type 

MAKE SURE ONLY THE RED BAR is selected, otherwise the whole graph will change type. We only need 

one of the series to change 

23. Select a Line chart 

Bam!! 

 

 

Sparklines 
 

Sparkline is a tiny chart in a worksheet cell that provides a visual representation of data. Use sparklines 

to show trends in a series of values, such as seasonal increases or decreases, economic cycles, or to 

highlight maximum and minimum values. Position a sparkline near its data for greatest impact. 

https://support.office.com/en-us/article/Use-sparklines-to-show-data-trends-1474e169-008c-4783-

926b-5c60e620f5ca 

 

Go to worksheet Sparklines 

 

1. Select the cells B1 to G6 

 All the data points of the Sales and Profits – First half 

 

2. Insert - > go to Sprarklines section->Line 
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3. in the Location Range - > select the cells at the end of the data points (H3:H6) 

 

 

4. Press OK 

 

5. Go to Sparkline Tools and click on the Markers  

 

 

5. Do the same for the PERCENTAGE CHANGE and select the Column sparklines 

Remember to also highlight the empty spaces for January 
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You can also click on the High Point to highlight the highest bar 

 

 

 

 

 

Formatting a graph 
 

Instructions during the training 

 

 

  

PERCENTAGE CHANGE

% Sales Change 50.0% 44.4% 53.8% 2.5% 2.4%

% Profits Change 150.0% 180.0% 28.6% -16.7% -60.0%

% Expenses Change 30.0% -7.7% 83.3% 18.2% 38.5%
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SHEET MANIPULATION 
 

Use the Various.xls workbook 

 

Protect cells – worksheet - workbook 
 

Go to the Employees worksheet 

By default all cells in a worksheet are marked as protected, but the protection is not enabled until you 

protect the worksheet 

So you can Unprotect some cells you want to allow the users to change, and then protect the 

worksheet. 

Click anywhere in the Employees table and press CTRL-A to select the entire table 

Right click on a selected area (random cells) and select Format cells 

Go to Protection 

You can see that the cells are locked. Uncheck the Locked 

 

 

Protect worksheet 
Go to Review tab and click Protect Sheet 

You can set a password if you want 

p.s. if you forget the password there is a tone of sources in the web to break it. So don’t count on that so 

much for maximum protection. It is a way to protect the cells from accidental modification or deletion 

 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 35 of 111 

 

 

Protect workbook 
You can also protect the entire Workbook  

Go to Review tab, Protect workbook 

 

This protects the workbook from adding or deleting worksheets 

Note: If you are using Excel 2010 and earlier, you can also select the Windows option if you want to 

prevent users from moving, resizing, or closing the workbook window, or hide/unhide windows. The 

Windows option is unavailable in Excel 2013 and later versions. 
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Renaming – Copying – Moving worksheets 
 

Right-click on a worksheet name 

 

 

 

You can change the Tab color of the worksheet or Rename the worksheet 

You can also Move or Copy the worksheet 

Either copy it (check the Create a copy) in the same worksheet, or move it or copy it in another, or a new 

workbook 
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Freeze Panes 
 

Go to View-> Freeze Panes 

 

 

a) If the headers are in the top row, then select Freeze Top row 

b)If the headers of the table are not on the first row of the worksheet, then select the row just after the 

headers and select Freeze Panes  

 

c) f you want both the header and a left column to be visible, select a single cell indicating the 

intersection of the header and the left column you want to keep visible when you scroll 

In the example below, both the Employee Name and the headers will be visible as you scroll to the right 
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DATE AND TIME FUNCTIONS 
 

Use the Various.xlsx workbook and go to Date&Time worksheet 

Notice the date column. We see numbers instead of dates. This is the serial number of the date. It is 

how many days have passed since 01/01/1900. Yeah.. I know.. whatever Excel  

To convert these into real date format: 

1.Highlight the range of dates and right click 

2. Select Format cells 

3. Click on the Date in the Category section 

Also, see the rest of the options in the different types of date formats. 

 

 

4. Type anywhere  

=TODAY()   Returns the current Date. When you open the worksheet on another day, that day will 

appear 

=NOW()    Return the current Date & Time 

Now, lets extract the month out of each date 

5. Go to cell I2 and type 

=MONTH(H2) 

You get the number of the month 
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However, we want the name of the month 

6. Go to cell J2 and type 

=TEXT(H2,"mmmm")    Answer = August 

7. Now type 

=TEXT(H2,"mmm")   That is three m’s. Answer = Aug   You get the point with the number of m’s  

Lets extract the Year 

8. In the next column, type 

=YEAR(H2) 

9. In the next column type 

=DAY(H2) 

you get the serial number of the day (1,2,3,4,5,6,.. 31) 

10. Now, type  

=TEXT(H2,”dddd”)  or =TEXT(H2,”ddd”)   that is 3 d’s 

NOTE: APPLY THE TEXT function only on the dates!!! NOT ON THE NUMBERS derived by the Day 

function, or the Month function.  

 

Now, lets calculate the Age of each person 

We have two ways of doing that 

A. Subtract the birth date from the current date 

=TODAY()-H2   this will give you the number of days that have passed  

You can then divide by 365 days to get the number of year 

=(TODAY()-H2)/365 

OR you can use this function 

=INT(YEARFRAC(birth_day;TODAY())) 

FINAL NOTE 

If we want to combine the Year, Month and Day into a DATE, we use the DATE Function 

=DATE(supplytheYear,supplytheMonth,supplytheDay) 

You supply the Year, Month and Day in numeric format, not in text format!!! 

=DATE(2017,08,16)  will return..  16/08/2017  
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Date and time functions. The following list is taken from the Microsoft Support page 

Press CTRL and lick here to go to the page 

You can press CTRL and click on each function to go the individual support page for each function 

Function Description 

DATE function Returns the serial number of a particular date 

DATEVALUE function Converts a date in the form of text to a serial number 

DAY function Converts a serial number to a day of the month 

DAYS function  

 

Returns the number of days between two dates 

HOUR function Converts a serial number to an hour 

ISOWEEKNUM function  

 

Returns the number of the ISO week number of the year for a given 

date 

MINUTE function Converts a serial number to a minute 

MONTH function  Converts a serial number to a month 

NETWORKDAYS function Returns the number of whole workdays between two dates 

NETWORKDAYS.INTL function  

 

Returns the number of whole workdays between two dates using 

parameters to indicate which and how many days are weekend days 

NOW function  Returns the serial number of the current date and time 

SECOND function Converts a serial number to a second 

TIME function Returns the serial number of a particular time 

TIMEVALUE function Converts a time in the form of text to a serial number 

TODAY function  Returns the serial number of today's date 

WEEKDAY function Converts a serial number to a day of the week 

WEEKNUM function Converts a serial number to a number representing where the week 

falls numerically with a year 

WORKDAY function  Returns the serial number of the date before or after a specified 

number of workdays 

YEAR function Converts a serial number to a year 

YEARFRAC function Returns the year fraction representing the number of whole days 

between start_date and end_date 

I ve deleted a few so go to the website to see some more 

https://support.office.com/en-us/article/Date-and-time-functions-reference-fd1b5961-c1ae-4677-be58-074152f97b81?ui=en-US&rs=en-US&ad=US&fromAR=1
https://support.office.com/en-us/article/DATE-function-e36c0c8c-4104-49da-ab83-82328b832349
https://support.office.com/en-us/article/DATEVALUE-function-df8b07d4-7761-4a93-bc33-b7471bbff252
https://support.office.com/en-us/article/DAY-function-8a7d1cbb-6c7d-4ba1-8aea-25c134d03101
https://support.office.com/en-us/article/DAYS-function-57740535-d549-4395-8728-0f07bff0b9df
https://support.office.com/en-us/article/HOUR-function-a3afa879-86cb-4339-b1b5-2dd2d7310ac7
https://support.office.com/en-us/article/ISOWEEKNUM-function-1c2d0afe-d25b-4ab1-8894-8d0520e90e0e
https://support.office.com/en-us/article/MINUTE-function-af728df0-05c4-4b07-9eed-a84801a60589
https://support.office.com/en-us/article/MONTH-function-579a2881-199b-48b2-ab90-ddba0eba86e8
https://support.office.com/en-us/article/NETWORKDAYS-function-48e717bf-a7a3-495f-969e-5005e3eb18e7
https://support.office.com/en-us/article/NETWORKDAYSINTL-function-a9b26239-4f20-46a1-9ab8-4e925bfd5e28
https://support.office.com/en-us/article/NOW-function-3337fd29-145a-4347-b2e6-20c904739c46
https://support.office.com/en-us/article/SECOND-function-740d1cfc-553c-4099-b668-80eaa24e8af1
https://support.office.com/en-us/article/TIME-function-9a5aff99-8f7d-4611-845e-747d0b8d5457
https://support.office.com/en-us/article/TIMEVALUE-function-0b615c12-33d8-4431-bf3d-f3eb6d186645
https://support.office.com/en-us/article/TODAY-function-5eb3078d-a82c-4736-8930-2f51a028fdd9
https://support.office.com/en-us/article/WEEKDAY-function-60e44483-2ed1-439f-8bd0-e404c190949a
https://support.office.com/en-us/article/WEEKNUM-function-e5c43a03-b4ab-426c-b411-b18c13c75340
https://support.office.com/en-us/article/WORKDAY-function-f764a5b7-05fc-4494-9486-60d494efbf33
https://support.office.com/en-us/article/YEAR-function-c64f017a-1354-490d-981f-578e8ec8d3b9
https://support.office.com/en-us/article/YEARFRAC-function-3844141e-c76d-4143-82b6-208454ddc6a8
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STRING FUNCTIONS 
 

Use the workbook String functions.xlsx 

Go to worksheet String Functions 

CONCATENATE 
Use CONCATENATE, one of the text functions, to join two or more text strings into one string. 

=CONCATENATE(text1, [text2], ...) 

The CONCATENATE function syntax has the following arguments: 

Text1 (required) The first item to join. The item can be text value, number or cell reference. 
Text2 Additional text items to join. You can have up to 255 items, up to 8,192 characters. 

 

Example: In cell H6 use the CONCATENATE formula =CONCATENATE(F6," ",G6). 

The & operator is another way to concatenate cells. Similarly, to the CONCATENATE function, you can use 

"&" in Excel to combine different text strings, cell values and results returned by other functions. 

Example: In cell H7 use the formula =F6&" "&G6 

UPPER 
UPPER converts text to uppercase. 

=UPPER(text) 

The UPPER function syntax has the following arguments: 

Text    Required. The text you want converted to uppercase. Text can be a reference or text string. 
 

Example: Convert the name from cell F11 to cell H11 using the formula =UPPER(F11)  

LOWER 
Converts all uppercase letters in a text string to lowercase. 

=LOWER(text) 

The LOWER function syntax has the following arguments: 

 Text    Required. The text you want to convert to lowercase. LOWER does not change characters in 
text that are not letters. 

Example: Convert in lower cases characters the name (cell F14) to cell H14 using the formula =LOWER(F14) 
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PROPER 
Proper capitalizes the first letter in a text string and any other letters in text that follow any character 
other than a letter. Converts all other letters to lowercase letters. 
 

 =PROPER(text) 

The PROPER function syntax has the following arguments: 

 Text    Required. Text enclosed in quotation marks, a formula that returns text, or a reference to a cell 
containing the text you want to partially capitalize. 

Example: In cell H17 apply the formula =PROPER(F17). 

 

TRIM 

TRIM removes all spaces from text except for single spaces between words. Use TRIM on text that you 
have received from another application that may have irregular spacing.  

=TRIM(text) 

The TRIM function syntax has the following arguments: 

 Text    Required. The text from which you want spaces removed. 

Example: Trim the text from cell F20 using the formula =TRIM(F20) in cell H20. 

 

FIND 
FIND locates one text string within a second text string, and return the number of the starting position of 
the first text string from the first character of the second text string. 
 

=FIND(find_text, within_text, [start_num]) 

The FIND function syntax has the following arguments: 

 Find_text    Required. The text you want to find. 
 Within_text    Required. The text containing the text you want to find. 
 Start_num    Optional. Specifies the character at which to start the search. The first character in 

within_text is character number 1. If you omit start_num, it is assumed to be 1. 
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Remarks 

 FIND is case sensitive and don't allow wildcard characters. If you don't want to do a case sensitive search 
or use wildcard characters, you can use SEARCH. 

 If find_text is "" (empty text), FIND matches the first character in the search string (that is, the character 
numbered start_num or 1). 

 Find_text cannot contain any wildcard characters. 
 If find_text does not appear in within_text, FIND returns the #VALUE! error value. 
 If start_num is not greater than zero, FIND returns the #VALUE! error value. 
 If start_num is greater than the length of within_text, FIND returns the #VALUE! error value. 
 Use start_num to skip a specified number of characters. Using FIND as an example, suppose you are 

working with the text string "AYF0093.YoungMensApparel". To find the number of the first "Y" in the 
descriptive part of the text string, set start_num equal to 8 so that the serial-number portion of the text 
is not searched. FIND begins with character 8, finds find_text at the next character, and returns the 
number  

Example: In cell H23 use the formula  =FIND("Baker",F23,1) to find the position in text. 

 

SEARCH 
The SEARCH function locates one text string within a second text string, and return the number of the 

starting position of the first text string from the first character of the second text string.  

=SEARCH(find_text,within_text,[start_num]) 

The SEARCH function have the following arguments: 

 find_text    Required. The text that you want to find. You can use the wildcard characters — question mark 
(?) and asterisk (*) in find_text. A question mark matches any single character; an asterisk matches any 
sequence of characters. If you want to find an actual question mark or asterisk, type a tilde (~) before the 
character. 

 within_text    Required. The text in which you want to search for the value of the find_text argument. 
 start_num    Optional. The character number in the within_text argument at which you want to start 

searching.  

 

Remarks 

 The SEARCH function is not case sensitive. If you want to do a case sensitive search, you can use FIND. 
 You can use the wildcard characters — the question mark (?) and asterisk (*) — in 

the find_text argument. A question mark matches any single character; an asterisk matches any 
sequence of characters. If you want to find an actual question mark or asterisk, type a tilde (~) before 
the character. 
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 If the value of find_text is not found, the #VALUE! error value is returned. 
 If the start_num argument is omitted, it is assumed to be 1. 
 If start_num is not greater than 0 (zero) or is greater than the length of the within_text argument, the 

#VALUE! error value is returned. 
 Use start_num to skip a specified number of characters. Using the SEARCH function as an example, 

suppose you are working with the text string "AYF0093.YoungMensApparel". To find the position of the 
first "Y" in the descriptive part of the text string, set start_num equal to 8 so that the serial number 
portion of the text (in this case, "AYF0093") is not searched. The SEARCH function starts the search 
operation at the eighth character position, finds the character that is specified in the find_text argument 
at the next position, and returns the number 9. The SEARCH function always returns the number of 
characters from the start of the within_text argument, counting the characters you skip if 
the start_num argument is greater than 1. 

Example: In cell H26 use the formula =SEARCH("?akER",F26).  

LEFT 
LEFT returns the first character or characters in a text string, based on the number of characters you 
specify. 
 

=LEFT(text, [num_chars) 
 
The function syntax has the following arguments: 
 
Text    Required. The text string that contains the characters you want to extract. 
Num_chars    Optional. Specifies the number of characters you want LEFT to extract. 

 Num_chars must be greater than or equal to zero. 

 If num_chars is greater than the length of text, LEFT returns all of text. 

 If num_chars is omitted, it is assumed to be 1. 
 

Example: In cell H30 use the formula =LEFT(F30,3). 

 

MID 
MID returns a specific number of characters from a text string, starting at the position you specify, based 
on the number of characters you specify. 
 

=MID(text, start_num, num_chars) 

The MID function syntax has the following arguments: 

 Text    Required. The text string containing the characters you want to extract. 
 Start_num    Required. The position of the first character you want to extract in text. The 

first character in text has start_num 1, and so on. 
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 Num_chars    Required. Specifies the number of characters you want MID to return from 
text. 

 

Remarks 

 If start_num is greater than the length of text, MID returns "" (empty text). 
 If start_num is less than the length of text, but start_num plus num_chars exceeds the length of text, 

MID returns the characters up to the end of text. 
 If start_num is less than 1, MID returns the #VALUE! error value. 
 If num_chars is negative, MID returns the #VALUE! error value. 
 If num_bytes is negative, MIDB returns the #VALUE! error value. 

Example: In cell H33 apply the formula =MID(F33,4,3). 

RIGHT 
RIGHT returns the last character or characters in a text string, based on the number of characters you 
specify. 
 

=RIGHT(text,[num_chars]) 
 
The RIGHT function has the following arguments: 
Text    Required. The text string containing the characters you want to extract. 
Num_chars    Optional. Specifies the number of characters you want RIGHT to extract. 
 

 
Remarks 

 Num_chars must be greater than or equal to zero. 
 If num_chars is greater than the length of text, RIGHT returns all of text. 
 If num_chars is omitted, it is assumed to be 1. 

 
Example: In cell H36 apply the formula =RIGHT(F36,4). 

 

LEN 
LEN returns the number of characters in a text string. 
 

=LEN(text) 
The LEN function syntax has the following arguments: 
Text    Required. The text whose length you want to find. Spaces count as characters. 
Example 
 

Example: Apply the formula =LEN(F39) in cell H39. 
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SUBSITUTE 
Substitutes new_text for old_text in a text string. Use SUBSTITUTE when you want to replace specific 
text in a text string. 
 

=SUBSTITUTE(text, old_text, new_text, [instance_num]) 
The SUBSTITUTE function syntax has the following arguments: 
Text    Required. The text or the reference to a cell containing text for which you want to 
substitute characters. 
Old_text    Required. The text you want to replace. 
New_text    Required. The text you want to replace old_text with. 
Instance_num    Optional. Specifies which occurrence of old_text you want to replace with 
new_text. If you specify instance_num, only that instance of old_text is replaced. 
Otherwise, every occurrence of old_text in text is changed to new_text. 
 

 

Example: Apply the formula =SUBSTITUTE(F42,"&","and") in cell H42. 

 

Note: Use REPLACE when you want to replace any text that occurs in a specific location in a text string. 

 

REPLACE 
REPLACE replaces part of a text string, based on the number of characters you specify, with a different 
text string 
 

=REPLACE(old_text, start_num, num_chars, new_text) 
 
The REPLACE function syntax has the following arguments: 
Old_text    Required. Text in which you want to replace some characters. 
Start_num    Required. The position of the character in old_text that you want to replace 
with new_text. 
Num_chars    Required. The number of characters in old_text that you want REPLACE to 
replace with new_text. 
New_text    Required. The text that will replace characters in old_text. 
 

Example: Use the formula =REPLACE(F45,3,1,"") in cell H45. 

Insert a line break in a cell 

To add spacing between lines or paragraphs of text in a cell, use a keyboard shortcut to add a new line. 

1. Double-click in cell H47. 
2. Click the location where you want to break the line. 
3. Press ALT+ENTER to insert the line break. 
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Add a Line Break in a Formula (CHAR10) 
 

To add a line break, you can use the Excel CHAR function, with the number 10. Use the & operator to 
join the line break character to the other text in the formula. 
 
So, if we want to get “Full name: Frank Baker” we can use the formula  
=F49&CHAR(10)&F50&" "&F51. 

After you add the line break, and press Enter, you might see a strange little box, where the line break 
should be or no line break.  

The Wrap Text feature isn’t automatically turned on, when you add a line break in a formula. You’ll have 
to turn it on yourself. 

Select the cell with the line break in the formula, and on the Home tab, click the Wrap Text command. 

 

Then, you’ll see the line break in the cell, instead of the little square. 
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Practice worksheet 
A dataset is not always neat and tidy. Most of the times when downloading data from a website or a 

server you must “fix” your data before starting to apply formulas, analyzing etc. 

Go to Formulas worksheet. There you will see a dataset downloaded from the yellow pages website. 

Let’s take a closer look at the data. In the first column (column A) it is displayed the organization name. If 

you click in some of the cells in column A you will see that same have a space character at the beginning, 

some at the end and same have double space between two words. In the second column (column B) we 

have telephone numbers but in some cases more data are inputted such as City branch, address etc.  In 

the third column (column C) we have the full address for each organization (street number, area and 

postal code and city). In column D we have the category of each organization. 

 

The first thing we must do is to TRIM our data.  

Insert a new column (Organization -trimmed) next to column A and apply the formula =TRIM (A2) and 

click ENTER. The space characters at the begging, in between and end of the text is now removed. Drag 

the formula down to apply to all rows. Select column B with your new trimmed organization names, copy 

and paste as values in column A and delete column B. 

 

To create a column that contains only the phone number for each organization:  

1. Insert a new column (Telephone number - new) next to the Telephone number (??). 

2. Apply the TRIM function = TRIM(B2) in cell C2. 

3. Drag down the formula.  

4. You can now see that not all cells are trimmed!  

This is due to different space characters (HTML nonbreaking spaces, decimal character code 160, 

rather than ASCII spaces, decimal character code 32). 

5. We will now use SUBSTITUTE function which substitutes new_text for old_text in a text string.  

Apply the formula =TRIM(SUBSTITUTE(B2,CHAR(160),CHAR(32))). This formula first substitutes 

the HTML nonbreaking spaces, decimal character code 160 to ASCII spaces, decimal character 

code 32 and then trims the text. 

6. Insert a new column right of the column C (Name it Telephone number only). 

7. Apply the LEFT function in column D. 

 

Telephone numbers in Cyprus are 8-digit numbers so if we apply the formula =LEFT(B2,8) we will get in 
cell D2 only the telephone number for Famagusta Red Cross. Drag the formula down to get the telephone 
numbers for all the organizations. Copy and paste as values the data from column D. 
 
 
For the rest information in column B:  

1. Insert a new column next to column D and name it Other information (column E). We will now 
use the RIGHT and LEN function. 
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Type =RIGHT(C2,LEN(C2)-LEN(D2)-1) in cell E2 
 
The formula first find the length of cell C2, then subtracts the length of cell D2 and returns in cell E2 the 
rest of the text from cell C2 without the phone number.  
-1 is for removing the space after the phone number. 
 
#VALUE appears where there is no other data except the phone number.  
To remove #value. Copy and paste as values the data in column E > go to Home tab > Editing group > Sort 
& Filter > Filter > Select #VALUE > delete. 
You can also remove #VALUE with the formula =IFERROR(RIGHT(C2,LEN(C2)-LEN(D2)-1),""). 
 

 
 
So now we have in column D only the phone numbers and in column E the extra information. In some 
cases, is the address we will need for the next step (see cell E16). 
 

 
 
To fix this you have to check your data in column E and if it is an address copy it in column F.  
 
When done delete columns B and C. You should now have a worksheet as in the picture that follows. 
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Now, if you want to separate the full address to Street and street number, Area and Postal code and City:  
 
 

1. First, trim cells in column D (Insert new column (Address (full) -trimmed> apply formula =TRIM(D2) 
> drag formula down > copy and paste as values in same column (column E).  

2. Next, we have to decide in how many new columns we want to split our data from column E. 
Notice how many comma characters there are in your data. In some cases, there are four commas 
in the address (street and street number, building name, apartment, postal code and area, city) 
so insert five columns to the right of column E (Address full- trimmed). 

3. Select entire column E and go to the Data tab, Data Tools and click Text to Columns. 
4. In the Convert Text to Columns Wizard  - Step 1 select Delimited and click Next.  
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5. In Step 2 select the Comma delimiter and click Next.

 
 

6. In Step 3 choose the destination in which you want your data sent. In this case is columns F, G, H, 
I, J (F:J) and then click Finish. 
 

 
 

 
Again, you must go through your data and fix manually the “wrong” results. 

 
7. Delete column E (Address full -trimmed). 
8. Rename new column E to Street and street number, column F to Area and postal code and column 

G to City. 
9. Make sure column H and I are now blank and then delete them. Also, delete column D. 

 
This is how your worksheet should be. 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 52 of 111 

 
 
 

10. Columns E (Area and postal code) and F (City) need to be trimmed. As before insert a column next 
to column E and F apply TRIM function > copy and paste as values > delete extra columns. 
 
Your data is now ready to be analyzed! 
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ABSOLUTE AND RELATIVE REFERENCES 
 

By default, all cell references are relative references.  

When copied across multiple cells, they change based on the relative position of rows and columns. For 

example, if you copy the formula =A1+B1 from row 1 to row 2, the formula will become =A2+B2.  

But what if you don’t want the reference to be relative but instead to be absolute i.e. fixed 

 

Use the Various.xlsx workbook 

 

Go to the MixedReferences worksheet 

1. Calculate the total sales  

=SUM(D3:D7) 

or click on the cell at the bottom of the numbers (D8) and go to Home-section on the Ribbon and click 

the AutoSum button (!)  

 

 

Now that we have the total sales we want the percentage across each location 

2. In the cell E3 type =D3/D8 

In other words, divide the 500/1795 

3. Turn the number into a percentage % 

4. click on the % icon in the Home section 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 54 of 111 

 

 

5. Drag the formula down 

Something is wrong 

 

 

6.Go the formula again (in cell E2) and we need to “lock” the reference to the total i..e make it Absolute 

reference 

We can do this by adding the $ sign before the D and before the 8 in the reference D8 

That is “lock” the column D and the row 8 

 

YOU CAN also add the $ sign by pressing the F4 button 

You can repeatedly press the F4 button to see what happens 

Location Sales Percentage

Nicosia 500 28%

Limassol 300 #DIV/0!

Larnaca 400 #DIV/0!

Pafos 325 #DIV/0!

Paralimni 270 #DIV/0!

Total 1795
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It locks either the Column, Or the row, or both 

 

7. Drag the formula in E3 Down 

 

 

MIXED Referencing 
On the same worksheet, we have the following problem 

We need to allocate certain amount of Furniture to the five locations 

There are 4 types of furniture and 5 locations 

The allocation must be done according to the percentages shown below the locations 

 

Start by typing in cell C16  

8. =C15*B16   

9. Drag it Down to cell C19 

 

Problem! Row 15 is relative and it changes. So we need to lock row 15 within the formula 

10. Go in the formula of cell C16 and put a $ at the left of 15  

You can also change that using F4. Press it twice 

 

11. Now select range C16 to C19 

12. Drag them to the right until the column of Paralimni 

Location Sales Percentage

Nicosia 500 28%

Limassol 300 17%

Larnaca 400 22%

Pafos 325 18%

Paralimni 270 15%

Total 1795
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Again we have a problem 

 

That’s because the column B where the quantities are, is relative. So we need to lock this too! 

13. Go again to the original starting cell C16 

14. Place a $ on the left of B in the B19 

 

 

15. Now Drag the starting cell C16 down and then to the right (or to the right and then down. no 

problem) 

 

Great! 

Always make sure the row totals and the column totals are what is expected to be 

  

Item # Qty Allocation --- by Region

City Center Mall Marina Larnaca Paralimni

Furniture 25% 20% 30% 10% 15%

Couches 900 225 180 270 90 135

Recl iners 800 200 160 240 80 120

Coffee Tables 600 150 120 180 60 90

End Tables 200 50 40 60 20 30
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CONDITIONAL FORMATTING 
 

1. Go to worksheet Conditional formatting. 

2. Click any cell with data.  

3. Insert tab > Tables group > Table.  

4. In the dialogue box Create Table make sure My table has headers is cheeked and click OK. (You 

can also click on a cell of your data and the CTR+T).  

 

Your data is now an excel table.  

Note: To remove table settings >Right click your Table > Table > Choose Convert to Range. 

 

Highlight Cells Rules 
 

Duplicate values 
1. Select column Account. 

2. Home tab >Styles group >click the arrow next to Conditional Formatting > Highlight Cells Rules 

> Duplicate Values. 

 

A new dialogue box opens that indicates the conditional formatting you want to apply (Duplicates) and 

the style of format which will apply.  

 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 58 of 111 

  

You can change the highlight style by clicking on the arrow next to the formatting style and select another 

style or customize your own. 

 

Greater than 
 

1. Select column Age.  

2. Home tab > Styles group > arrow next to Conditional Formatting > Highlight Cells Rules > 

Greater Than. 

3. In the dialogue box, Greater Than you type the value which if the cell number is above will be 

highlighted.  

 

4. Type the number 80 in the dialogue box. 

 

Again, you can change the highlight style by clicking on the right of the formatting style and selecting 

another style or customize your own. 
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Top/Bottom Rules 
 

1. Select column #Visits.  

2. Home tab > Styles group > arrow next to Conditional Formatting > Top/Bottom Rules > Top 10 

Items. 

3. In the dialogue box Top 10 Items you must type the TOP values you want to be highlighted.  Type 

3 to get the top 3 visitors. 

 

 

 

Again, you can change the highlight style by clicking on the right of the formatting style and selecting 

another style or customize your own. 

Likewise, you can highlight the persons with the least visits (Home tab > Styles group > click the arrow 

next to Conditional Formatting > hover over Top/Bottom Rules > click Bottom 10 Items). 

 

Data Bars 
1. Select column #Visits2.  

2. Home tab > Styles group > arrow next to Conditional Formatting > Data Bars > select a color and 

style. 
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Color Scales 
1. Select column #Visits3. 

2. Home tab > Styles group > arrow next to Conditional Formatting > Color Scales > click on the first 

style in the third row.  

The top color represents the high values, the center color the middle values and the color to the bottom 

the low values. 

Lowest values are highlighted white and highest values green.  

You can choose the format style (Home > Styles group > click the arrow next to Conditional Formatting > 

hover over Color Scales > click on More Rules. 

 

Icon Sets 
1. Select column #Visits4 

2. Home tab > Styles group > arrow next to Conditional Formatting > Icon Sets > the second set of 

Indicators.  
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3. You can customize the icon set by clicking More Rules. 

 

You can input the value and/ or type for each icon or you can assign the values in other cells in your 

worksheet. 
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New Rule 
To find blank cells in table 

1. Select column Postal code. 

2. Home tab > Styles group > arrow next to Conditional Formatting >  New Rule.  

 

2. Click Use a formula to determine which cells to format. 
3. Under Format values where this formula is true, enter your formula =K3="" 
4. Click Format. 
5. Use the controls on the Number, Font, Border, and Fill tabs to change your data, or the cells 

around your data. 

Clear Rules 

To clear a conditional formatting rule, execute the following steps. 

1. Select column #Visits4. 
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2. Home tab > Conditional Formatting > Clear Rules > Clear Rules from Selected Cells. 

 

Manage Rules 
1. Home tab > Styles group > arrow next to Conditional Formatting > Manage Rules.  

2. In Conditional Formatting Rules Manager chance rules by clicking Edit Rule. 
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Find cells that have conditional formats 

1. Click any cell without a conditional format. 
2. Home tab > Editing group > arrow next to Find & Select > Conditional Formatting. 

 

Find only cells with the same conditional format 

1. Click the cell that has the conditional format that you want to find. 
2. Home tab >  Editing group >  arrow next to Find & Select >  Go To Special. 

 

3. Click Conditional formats. 
4. Click Same under Data validation. 

Copy and paste conditional formatting to other cells 
1. Click the cell that has the conditional formatting you want to copy. 

2. Click Home > Format Painter. 

 

The pointer changes to a paintbrush. 

TIP:  You can double-click Format Painter if you want to keep using the paintbrush to paste the conditional 

formatting in other cells. 

3. To paste the conditional formatting, drag the paintbrush across the cells or ranges of cells you 

want to format. 

To stop using the paintbrush, press Esc. 
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Search Box 
2. Label the search box (thick outside borders), and add a fill color. 
3. Next, name the cell "search_box" (Home tab > box in left corner > type “search_box).  
4. Select the entire data range, and add a custom conditional formatting rule that uses a formula. 

(Home tab > Styles group, click the arrow next to Conditional Formatting > New Rule > Use a  
formula to determine which cells to format). 

 

To make the rule flexible, we're going to use the SEARCH function. Remember, SEARCH takes 3 arguments: 
the text to search for, the text to look within, and, optionally, a starting position. When SEARCH finds 
something, it returns the position as a number. If the text is not found, it returns zero. 

In the Format values where this formula is TRUE type the formula  
=SEARCH(search_box,$D4&$E4&$F4&$G4&$H4&$I4&$J4) 
 

https://exceljet.net/excel-functions/excel-SEARCH-function
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This formula uses SEARCH to look for text in search_box inside columns C, D, E, and F, glued together 
with concatenation. Make sure the row number matches the row of the active cell. 
The key to understanding this rule is to remember that it will be evaluated for each cell in the table. The 
dollar signs lock the columns, but the rows are free to change. 

When SEARCH returns any number but zero, the rule will fire and the conditional formatting will be 
applied. 

5. Now add a light fill that matches the color of the search box, and complete the rule (Click Format 
> Fill tab). 

 

The searchbox is now functional. You don't have to enter complete words, because the SEARCH function 
just matches text. 
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There is a problem, though. If we clear the search_box, all rows are highlighted. That's because SEARCH 
returns the number 1 if the text to find is empty. 

You can fix this problem by wrapping the SEARCH function in an IF statement that returns zero when the 
search box is empty. 

Use the formula:  

=IF(ISBLANK(search_box),0, SEARCH(search_box,$D4&$E4&$F4&$G4&$H4&$I4&$J4)) 
 

 
 
Now, no rows are highlighted when the search box is empty, but the rule still fires when text is entered. 

  

https://exceljet.net/excel-functions/excel-IF-function
https://exceljet.net/excel-functions/excel-ISBLANK-function
https://exceljet.net/excel-functions/excel-SEARCH-function
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CONDITIONALS 
Use the workbook conditionals.xlsx and the worksheet Conditionals 

Here it is best of we create Named Ranges for the ranges we will be using 

 

1. Select the entire table  

 You can easily do that by pressing CTRL-A 

2. Go to Formulas - > Create from Selection 

3. Click only the Top Row 

 

4. Go to Name Manager and see the named ranges you created 
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There are 300 products in the list. They are not exactly unique but some products come in different 

colors 

1. Question  

How many items are there with the description Department = Kitchen? 

Here we will use the COUNTIF function 

Go to cell K4 

=COUNTIF(Department,J4) 

The formula counts how many entries are there in the Department list (named range) that match the 

criteria defined in cell J4 – which is the kitchen 

Now drag the cell down to get the rest of the counts 

 

Of course we could do that without the Named Ranges and just use the $A$4:$A$303 range 

 

2. Question 

How much in total revenue from each Department? 

Here we will use the SUMIF function 

 

=SUMIF(Department,J4,Revenue) 

The formula uses three (3) arguments 

 

 

The range is the range of data for the criteria to applied to. Then you define the range to sum 

The formula states that take the sum of Revenue, when the Department (Range) = Kitchen (Criteria) 

3. Similarly we can get the average revenue from each department 

 

=AVERAGEIF(Department,J4,Revenue) 

 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 70 of 111 

4. Question 

How much revenue in total from Dining Furniture? 

Here we have two criteria: 

 a) Category must be Furniture 

 b) Department must be Dining 

and we want to get the total revenue (i.e. SUM the revenue) 

 

We will use the SUMIFS function which accommodates more than one criteria 

Go to any empty cell and type 

=SUMIFS (Revenue, Department, ”Dining”, Category, ”Furniture”) 

or instead of writing “Dining” and “Furniture” you can reference these values in the cells K13 and K14 
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IF STATEMENT 
 

Excel IF function - syntax and usage 

The IF function is one of Excel's logical functions that evaluates a certain condition and returns the value 

you specify if the condition is TRUE, and another value if the condition is FALSE. 

The syntax for Excel IF is as follows: 

IF(logical_test, [value_if_true], [value_if_false]) 

As you see, the IF function has 3 arguments, but only the first one is obligatory, the other two are 

optional. 

logical_test - a value or logical expression that can be either TRUE or FALSE. Required.In this argument, 

you can specify a text value, date, number, or any comparison operator.  

value_if_true - the value to return when the logical test evaluates to TRUE, i.e. if the condition is met. 

Optional. 

value_if_false - the value to be returned if the logical test evaluates to FALSE, i.e. if the condition is not 

met. Optional. 

 

Go to Worksheet IF Function 

We have a orders and the subtotal (before shipping cost) 

We need to specify whether the order total is less than 1000 euros 

1. Go to cell G5 and type 

=IF(F5<1000,"<1000","") 

If the subtotal is less than 100, then write “<1000”. If NOT then leave empty (“”)  

 

2. Go to cell H5 and type 

=IF(F5<$L$5,50,F5*1%) 

Tis checks if the subtotal is less than 100, then the sipping cost is 50, ELSE multiply the subtotal by 1%  

 

We can now combine all this in the Total 2 calculation 

3. Go to cell J5 and type  

=IF(F5<$L$5,F5+$M$5,F5*1%+F5) 
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PARTIAL MATCH 
IF formula for text values with partial match 

If you want to base your condition on a partial match rather than exact match.  

A solution is to use IF in combination with ISNUMBER and SEARCH (case-insensitive) or FIND (case-

sensitive) functions. 

Use the PartialMatch worksheet 

For example, if No action is required both for "Delivered" and "Out for delivery" items, the following 

formula will work a treat: 

=IF(ISNUMBER(SEARCH("deliv",B2)), "No", "Yes") 

 

We've used the SEARCH function in the above formula since a case-insensitive match suits better for our 

data. If you want a case-sensitive match, simply replace SEARCH with FIND in this way: 

=IF(ISNUMBER(FIND("text", where to search)), value_if_true, value_if_false) 

 

 

A great post here https://www.ablebits.com/office-addins-blog/2014/11/26/if-function-excel/ 

 

 

 

 

 

 

 

 

 

https://www.ablebits.com/office-addins-blog/2014/11/26/if-function-excel/
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Nested IF’s 
 

We can nest IF statements within IF statements 

 

Example: 

Go to worksheet NestedIfs 

 

We have a group of people and their age 

We need to recode their age into 3 categories: Child, Adult, Elder 

If the age is less than 18, then we have a child 

If the age is greater than 18 but less than 65, then we have an adult 

If the age is greater than 65 then we have an elder 

 

Go to cell J2 and type 

=IF(I2<18,"child",IF(I2<65,"adult","elder")) 

The point here is that we FIRST check whether the age is less than 18.If it is TRUE then we get the “child” 

category 

If NOT (FALSE), then we apply another IF statement, to check whether it is less than 65. 

IF TRUE (less than 65) then adult, Else is going to be an ELDER 

 

NOTE: the age cut-offs can be adjusted by referring to specific cells 

Type 

=IF(I2<E17,"child",IF(I2<E18,"adult","elder")) 

 

The cell E17 has the value of 18 and the cell E18 the value of 65.  

Drag down. 

 

Oups.. we forgot to lock the cells using absolute references 
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INFORMATION FUNCTIONS  
Go to Workbook Information Functions.xlsx  

Instructions will be given during the training 

 

ISBLANK 
Go to worksheet ISBLANK-ISNUMBER 

Let’s make a column that declares whether we have an email or not? 

Use the ISBLANK function along with the IF function 

2. Go to Workbook Varius.xlsx and to the worksheet IS ERROR 

 

ISERROR 
 

Go to worksheet ISERROR 

ISERROR() returns TRUE or FALSE 

If we multiply the TRUE*a1 = 1 

If we multiple FALSE*1=0 

So we can multiple the result of the ISERRROR and then add the column ti see how many errors we have 

 

ISNUMBER 
 

Go to worksheet ISBLANK-ISNUMBER 

Check whether the column Spending has numbers. Some numbers may be not be recognised as 

numbers but as text (because of the decimal separators) 
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Function Description 

ISBLANK function Returns TRUE if the value is blank 

ISERR function Returns TRUE if the value is any error value except #N/A 

ISERROR function Returns TRUE if the value is any error value 

ISEVEN function Returns TRUE if the number is even 

ISFORMULA function  

 

Returns TRUE if there is a reference to a cell that contains a 

formula 

ISLOGICAL function Returns TRUE if the value is a logical value 

ISNA function Returns TRUE if the value is the #N/A error value 

ISNONTEXT function  Returns TRUE if the value is not text 

ISNUMBER function Returns TRUE if the value is a number 

ISODD function  Returns TRUE if the number is odd 

 

 

https://support.office.com/en-us/article/Information-functions-reference-f953e38d-07e5-4602-b753-

1413810950e3 

 

 

  

https://support.office.com/en-us/article/ISBLANK-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISERR-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISERROR-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISEVEN-function-aa15929a-d77b-4fbb-92f4-2f479af55356
https://support.office.com/en-us/article/ISFORMULA-function-e4d1355f-7121-4ef2-801e-3839bfd6b1e5
https://support.office.com/en-us/article/ISLOGICAL-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISNA-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISNONTEXT-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISNUMBER-function-0f2d7971-6019-40a0-a171-f2d869135665
https://support.office.com/en-us/article/ISODD-function-1208a56d-4f10-4f44-a5fc-648cafd6c07a
https://support.office.com/en-us/article/Information-functions-reference-f953e38d-07e5-4602-b753-1413810950e3
https://support.office.com/en-us/article/Information-functions-reference-f953e38d-07e5-4602-b753-1413810950e3
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OUTLINING DATA 
 

Use the workbook OutlineData.xlsx 

 

Go to OutlineData worksheet 

To do an outlining of our data, we first must decide the fields upon we will do it 

 

Lets outline the data by Product and Region 

 

1. First SORT the data by the selected fields 

Select all the data: 

 Click on the upper left cell, Press CTRL-Shift-RIghtArrow – Down Arrow 

2. At the Ribbon go to Data->Sort 

In the Sort by box select Product. 

 Press Add Level, Select Region 

 

 

Now the data are first sorted by Product and then within each Product, sales are sorted by Region 

 

3. If the data are not still highlighted (as in ‘selected’) then select them again 

4. Go to the Ribbon->Data->Subtotal 

5. Select the Product in the At each change in: 

6. Select Sum in the Use function: 
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7. Select Total Cost at Add subtotal to: 

 

 

8. In the top left corner you will see number 1,2,3. This is the outlining 

 

9. Press 1 

 All is hidden, you can see the grand sum of the cost 

10.Press 2 

 You can see the subtotals by Product 

11. Press 3  

 You can see all the data 

12. Scroll down to row #709 

 You can see that there is a Chameleon Couch Total 

 The same goes for all the products as you go down the data 

Now lets add another criteria to add a subtotal. The Region 

 

13. Ribbon->Data->Subtotal 
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Select the Region in the At each change in: 

14. UNCHECK the Replace current subtotals 

 This is important since we need to see subtotals broken down by Product and Region 

 

Now there are four numbers, 1,2,3,4 in the top left corner of the outlining 

15.Press the 3 in the top left corner 

Now you can see a breakdown of the total sales by Product and by each Region 

 

You can also Hide or Show the details (collapse or expand the outlining) by using the buttons on the 

Data menu in the Ribbon next to the Subtotal 
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To Remove the Outlining 

DO NOT USE THE UNGROUP button!!! 

Go to Subtotal -> Remove All 

 

 

Group/ Ungroup rows and columns 
 

Go to Scenario worksheet 

 

1. Highlight Rows 5 and 6 

2. Go to Data->Group 

Now repeat the same with rows 10 - 13 

Also group rows 18 to 33 
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3. Go to the Outlining on the top left corner and press the 1 

You now see the three groups REVENUE, COST and EXPENSES grouped 

You can press on the +, or – button on the left to expand or collapse the rows 

 

 

Now lets group some Columns 

4. Do the same for the Months that precede the Quarters columns  

 

 

 

5. Click on cell M13 

6. Press Show Detail on the Ribbon  
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You can see that the Cost of Goods is expanded together with the 3rd Quarter 

 

To remove the outlining 

7. Go to Ungroup - > Clear Outline 
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FILTERING 

 
Use the Workbook Various.xlsx 

Use ‘Filtering worksheet 

 

TEXT FILTERS 
1. Go to the ribbon - > Data-> Filter 

2. Go to the Employee Name dropdown arrow  

 

 

 

3. Start typing.. Lisa and press OK 

You now filtered all the Lisa’s    

Let’s say you want to additionally see John  

4. Go to the Employee name again and start typing John – DO NOT PRESS OK yet 

5. Click on the Add current selection to filter – Press OK 

Now you can additionally see John and Lisa on the filtered list 
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You can also sort the filtered data 

6. Click anywhere on the Status column  

7. Go to Data-> and press A/z sort 

 

 

 

 

Now remove the filtering by: 

a) either clicking on the Filter button on the Ribbon 

 This will remove all the filters from the tables 

b) Go to the Employee name dropdown arrow and select ‘ Clear Filter from Employee name’ 

If you do it using the a) approach, then you need to re-press the Filter button for the filters and 

dropdown arrows to appear again 

 

You can now also filter so that you EXCLUDE something 

8. Go to the Employee name filter 

9. Select  -> Text Filter-> Custom filter 

10. In the first dropdown box, scroll down to find the ‘does not contain’ argument 

11. Type John in the adjacent box and click OK 

Now you have all the employees who are John  
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DATE FILTERS 
 

Since we have a Date column we can use filtering to select Months, Dates, Years or even Quarters 

8. Go to the Hire Date column and click on the dropdown arrow 

See that dates are organised by Years 

You can also click on the + symbol next to a year and see that months are collapsed 
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You can also click on the Date Filters arrow and you have a bunch of filtering criteria 

 

 

 

NUMBER FILTERING 
You can use filtering of numerical data 

9. Go to compensation column and click on the Number filters 

You can easily use Equals, Dows not equals, Less than etc. 

Se the list and play around 

The interesting filtering is in the Top 10! 

You can select 

a) Top or Bottom  

b) 10 or any other number 

c) Also you can select either the 10 items or 10% of the items 
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SEARCH AND RETRIEVE DATA 
 

VLOOKUP 
 

The VLOOKUP function uses 4 arguments (3 of them are compulsory, and 1, is not) 

 

 

The VLOOKUP searches down the first column in the  table_array  for a match to the value of 

lookup_value. 

It stops until it finds the FIRST match.  Be careful with this, in case  the table does not have unique 

entries (in the first column) 

It then goes across to the number of the column you specifiy in col_index_num 

It returns the value it gets 

 

Value of range_looukup 

This can take either the value of TRUE or FALSE 

If you omit (since this is not compulsory) the default is TRUE 

* when TRUE 

By default, the vlookup will find the closest match to our lookup_value and return a result.   

This method is best used for looking up numbers. 

To work correct the table_array  should be in Descending ORDER 

 

* when FALSE 

The function looks for an exact match. If does not find any exact match it will return #N/A 

There is NO NEED for the  table_array  to be sorted 
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A. Using the Approximate match 
Use the VLOOKUP-INDEX MATCH.xlsx workbook 

Go to the VLOOKUP-Approximate worksheet 

We have orders and the Subtotal cost for that order. We need to calculate a discount (Reduction 

column) based on the green table on the right. 

The table_array is the green table Reduction Rate. Note that the table is sorted in descending order, 0, 

500, 1000 etc. 

The reduction rate is on the 2nd column of the green table. 

We need to lookup the Subtotal in the 1st column of the Reduction rate table and return the appropriate 

discount rate which is in the 2nd column 

 

 

 

1. Go to cell E2 and type 

=VLOOKUP(D2,H2:I7,2) 

2. Drag the cell down 

Something is wrong isn’t it.. 

That’s because we forgot to “lock” the reference to the Reduction Rate table and the cell references are 

changing 

3. Go to a cell where #N/A appears and click on the formula to see what cells are being used to calculate  
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So lock the reference  

4. Go to the Reduction Rate in the first cell 

=VLOOKUP(D2,$H$2:$I$7,2) 

5. Drag it down 

IMPORTANT: Always CHECK SOME RANDOM CELLS to verify that the result is as expected to be!!!! 

 

B. Using the EXACT match 
 

Use the VLOOKUP-INDEX MATCH.xlsx workbook 

Go to the VLOOKUP-Exact worksheet 

 

Here we have a series of products in different colors and sizes and we need to fill in the Department and 

Category column based on the green table. 

 

The department is in the 2nd column so.. 

1. go to cell H3 (the first one to fill in the Department column) 

=VLOOKUP(A3,$K$2:$M$87,2,FALSE)  
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The Category is in the 3rd column so  

1. go to cell I3 (the first one to fill in the Category column) 

=VLOOKUP(A3,$K$2:$M$87,3,FALSE)  

 

 

A nice post https://www.excelcampus.com/functions/excel-vlookup-explained/ 

Common Errors 

#N/A - Occurs if the Vlookup function fails to find a match to the supplied lookup_value 
The cause of this will generally depend on the supplied [range_lookup]: 

if [range_lookup] = TRUE 

(or is omitted) 

- the #N/A error is likely to be because the smallest 

value in the lookup row is greater than the 

supplied lookup_value. 

if [range_lookup] = FALSE - the #N/A error is likely to be because an exact 

match to the lookup_value is not found in the 

lookup row. 

If you believe an exact match should have been 

found by the Hlookup function, see the Failure to 

Match Values page for details on how to diagnose 

and resolve this problem. 
 

#REF! - Occurs if the supplied row_index_num argument is greater than the number of rows in 
the supplied table_array. 

#VALUE! - Occurs if either: 

 The supplied row_index_num argument is < 1 or is non-numeric 
or 
 The supplied [range_lookup] argument is not recognised as TRUE or FALSE. 

 

 

https://www.excelcampus.com/functions/excel-vlookup-explained/
http://www.excelfunctions.net/FailureToMatchValues.html
http://www.excelfunctions.net/FailureToMatchValues.html
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C.HLOOKUP 
 

In this example, the Hlookup function searches through the top row of the table_array (the range A2-

F2), to find a match for the lookup_value (the name "Panos"). When the name "Panos" is found, the 

function returns the corresponding value from the 3rd row of the table_array that corresponds to the 

subject French 

=HLOOKUP(B10,A2:F6,3,FALSE) 

 

 

The function finds the name PANOS in the top row of the table_array and then returns the value '15%' 

from the 3rd row of the table_array. 

 

If we change the name in cell A10 of the spreadsheet from PANOS to Natasa, the Hlookup function 

would automatically recalculate the function to display the exam result for Natasa. 

 

 

A nice video here https://www.youtube.com/watch?v=5I--h_l0t7U 

 

 

 

 

 

  

https://www.youtube.com/watch?v=5I--h_l0t7U
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INDEX – MATCH 
 

The limitation of looking up in the first column only (using VLOOKUP), is vanished. We can perform all 

the kind of searches, and retrieve data from all around the table 

 

The MATCH function  

-returns the position of a value within a range 

We need to provide the lookup_value and where to look for it (lookup_array) 

 

Let’s find the position of Item 10 in the Item list 

We will reference Item 10 by the value at cell H2 

We ask to look it up in the Item list. REMEMBER to start from the first item in the item lit, i.e. do not 

include the header “Item” in the formula 

=MATCH(H2,B2:B11,0) 

The position is 10 (of course.. )  

Note that we have used the match_type=0 which means EXACT match 

 

The INDEX function 
- retrieves a value from a range of cells, when you provide the position you want 

The position can either be a column number or a row number. It depends on the case at hand 

=INDEX(array, row_num,[column_num]) 
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Now lets use the position of Item 10 and retrieve it’s Department 

=INDEX(C2:C11,I2) 

The I2 cell contains the number 10 

The range C2:C11 is lookup range and it is the Department list 

 

 

 

Now Let’s combine the two functions into ONE single formula 

 

The idea is that  

a) we can search in ANY column we want (as opposed to VLOOKUP that searches only only in the first 

column),  

b) Retrieve the row number 

c) use that row number to retrieve any value we want from WHATEVER column 

 

=INDEX(C2:C11, MATCH(H2,B2:B11,0)) 

That’s why it is called the INDEX MATCH approach.  

A nice post here http://www.contextures.com/xlFunctions03.html   

http://www.contextures.com/xlFunctions03.html
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STATISTICAL/ MATH FUNCTIONS 
Go to Various.xlsx workbook and use the worksheet Statistical Functions 

Step by step instructions will be given during the training 

FUNCTION SYNTAX DESCRIPTION 

AVERAGE 
=AVERAGE(number1, 
[number2], ...) 

Returns the average (arithmetic mean) of the 
arguments. 

COUNT =COUNT(value1, [value2], ...) Counts the number of cells that contain numbers 

COUNTA =COUNTA(value1, [value2], ...) 
Counts the number of cells that are not empty in a 
range. 

COUNTBLANK =COUNTBLANK(range) Counts empty cells in a specified range of cells. 

MAX 
=MAX(number1, [number2], 
...) Returns the largest value in a set of values. 

MAXIFS 

= 
MAXIFS(max_range, 
criteria_range1, criteria1, 
[criteria_range2, criteria2], ...) 

Returns the maximum value among cells specified by 
a given set of conditions or criteria. 

MEDIAN 
=MEDIAN(number1, 
[number2], ...) Returns the median of the given numbers. 

MIN =MIN(number1, [number2], ...) Returns the smallest number in a set of values. 

MINA =MINA(value1, [value2], ...) Returns the smallest value in the list of arguments. 

MINIFS 

=MINIFS(min_range, 
criteria_range1, criteria1, 
[criteria_range2, criteria2], ...) 

Returns the minimum value among cells specified by a 
given set of conditions or criteria. 

 

Math  

FUNCTION SYNTAX DESCRIPTION 
ABS =ABS(number) Returns the absolute value of a number. 

EXP =EXP(number) 

Returns e raised to the power of number. The 

constant e equals 2.71828182845904, the base 

of the natural logarithm. 

LN =LN(number) 

Returns the natural logarithm of a number. 

Natural logarithms are based on the constant e 

(2.71828182845904). 

RAND =RAND() 

Returns an evenly distributed random real number 
greater than or equal to 0 and less than 1. A new 
random real number is returned every time the 
worksheet is calculated. 

RANBETWEEN 
=RANDBETWEEN(bottom, 
top) 

Returns a random integer number between the numbers 
you specify. A new random integer number is returned 
every time the worksheet is calculated. 

ROUND =ROUND(number;num_digits) 
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ROUNDUP 
=ROUNDUP(number, 
num_digits) Rounds a number up, away from 0 (zero). 

ROUNDDOWN 
=ROUNDDOWN(number, 
num_digits) Rounds a number down, toward zero. 

SQRT =SQRT(number) Returns a positive square root. 

SUM =SUM(number1,[number2],...) Adds values. 

TRUNC 
=TRUNC(number, 
[num_digits]) 

Truncates a number to an integer by removing the 
fractional part of the number. 

Raise to the 
power use the ^  
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NAMED SCENARIOS 
 

Excel scenarios can be complex therefore a simple example will be demonstrated 

Use the Various.xlsx workbook 

Go to the Scenario worksheet 

Name the following cells (named ranges). Naming the cells is not required, but will make it easier to 

manage the scenarios, and read the reports: 

Name cell B1 as Dept 

Name cell B3 as Sales 

Name cell B4 as Expenses 

Name cell B6 as Profit 

In cell B6, enter the following formula: 

      =Sales - Expenses 

Create the First Excel Scenario 

On the Ribbon's Data tab, click What If Analysis 

Click Scenario Manager 

 

In the Scenario Manager, click the Add button 

Type name for the Scenario. For this example, use Marketing. 

Press the Tab key, to move to the Changing cells box 

On the worksheet, select cells B1 

Hold the Ctrl key, and select cells B3:B4 

Note: There is a limit of 32 changing cells 

Press the Tab key, to move to the Comment box 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 97 of 111 

(optional) Enter a comment that describes the scenario. 

Click the OK button 

 

The Scenario Values dialog box opens, with a box for each changing cell. 

 

You could modify these values, but in this example they contain the values currently on the worksheet, 

and don't need to be changed.  

Click the OK button, to return to the Scenario Manager. 

Click the Close button, to return to the worksheet   

Create the Second Excel Scenario 

To prepare for the Finance scenario, change the values in cells B1, B3 and B4, as shown below 

 

 

Budget 2017 Finance

Sales 800,000$             

Expenses 555,000$             

Profit 245,000$             
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On the Ribbon's Data tab, click What If Analysis, then click Scenario Manager. 

In the Scenario Manager, click the Add button 

Type name for the second Scenario. For this example, use Finance. 

The Changing cells box should show the previous selection -- B1,B3:B4 -- so leave that as is. 

Press the Tab key, to move to the Comment box 

(optional) Enter a comment that describes the scenario. 

Click the OK button 

The Scenario Values dialog box opens, with a box for each changing cell. 

Click the OK button, to return to the Scenario Manager. 

Click the Close button, to return to the worksheet   

Show an Excel Scenario 

Once you have created Scenarios, you can show them. In this example, the Finance scenario is currently 

visible. To change to a different scenario: 

On the Ribbon's Data tab, click What If Analysis, then click Scenario Manager. 

In the list of Scenarios, select Marketing 

Click the Show button 
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Add Scenario to Excel Ribbon 
An easier way to switch between Scenarios, is to add a command to the Ribbon. Follow these steps, to 
add a Custom Group, and put the Scenario command in that group. 

1. Right-click on the Ribbon, and click Customize the Ribbon 
2. From the drop down list at the top left, select All Commands 
3. In the list of commands that are currently on the Ribbon, click the plus sign for Data, then click 

Data Tools. That group contains the Scenario Manager, so we'll add the new group beside it. 

 

4. Below the list, click the New Group button. 
5. Then, click the Rename button, type Scenario as the name for the group, and click OK 

 

6. At the left, in the list of All Commands, scroll down to find Scenarios 
7. Make sure that the new Scenario group is still selected in the list at the right. 
8. Click on Scenarios, then click Add, to put Scenarios in the Scenario group. 
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9. Click OK, to close the window, then click the Data tab, and select a Scenario to view. 

 

 

Show the Excel Scenario Summary 

After you create the Excel Scenarios, you can view them in an Excel Scenario Summary. This lets you see 
the values and totals side-by-side, for an overall comparison. 

Note: The Excel Scenario Summary does NOT update automatically if you change the scenario values. 
You can delete the old summary and create a new one. 

To create a Scenario Summary: 

1. On the Ribbon, click the Data tab. 
2. Click What-If Analysis, then click Scenario Manager. (In earlier versions, click Tools>Scenarios) 
3. In the Scenario Manager, click Summary 
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4. In the Scenario Summary dialog box, for Report type, select Scenario Summary 
5. Click in the Result cells box, and on the worksheet, click the profit calculation cell (C6). 
6. Click OK, to close the dialog box. 
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RECORD A MACRO 
 

Use the Various.xlsx and go to Sheet 1  

 

Lets record a macro doing some formatting and calculations 

1. Go to View->Macros->Record a Macro 

 

 

2. Type a name for the macro 

 

 

We will: 

a) add columns after March and June to calculate the Quarter totals. Also the Grand total at the End 

b) Write the SUM functions 

c) Format the Page Layout to Landscape 
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d) Insert the Header and Footer 

 

 

 

To stop recording click the stop button at the lower left corner of excel 

 

 

 

 

Demonstration and step by step during the training 
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TIPS AND TRICKS 
 

A. Copy only the visible part of the data 
 

If you are using Subtotals or Hiding columns the data are still there. If you copy an area with hidden 

columns or rows, the hidden data are still being copied 

Solution 

Hit F5 - > Click on Special -> Select Visible cells only 

Then do your copy-pasting job! 

 

 

Figure 5 When F5 is pressed 

  

 

B. Sort from Left to Right 
 

Use the Sort worksheet in the Handy Excel Shortcuts 

 

Select the data 

Go to Sort and click on Options.  

Change the Orientation to .. Sort left to right 

Select the Row to sort by 

Figure 6 When Special is pressed 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 105 of 111 

 

 

B. Sort by Months, Years or Days 
 

Use sort by a DATE column 

Select Custom List  

In the custom lists select the format you want.  
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D. Extract unique values from a list 
 

You can see this in the Handy Excel Shortcuts.xls workbook and choose the ‘SalesPersons’ worksheet 

Use advanced filtering 

1. Select the entire list – INCLUDE THE FIELD NAME – or USE NAMED RANGES 

2. Go to Data-> next to the Filter click Advanced 

3. Click on the Copy to another location 

4. Click Unique Records only 

5. go to the Copy to: box and set where to copy the unique list 

 

 

 

E.HIDE FORMULAS 
 

Prevent a formula from displaying in the formula bar 

NOTE:  This procedure also prevents the cells that contain the formula from being edited. 

1. Select the range of cells whose formulas you want to hide. You can also select nonadjacent ranges or the 

entire sheet. 

2. On the Home tab, in the Cells group, click Format, and then click Format Cells. 

3. In the Format Cells dialog box, on the Protection tab, select the Hidden check box. 

4. Click OK. 

5. On the Review tab, in the Changes group, click Protect Sheet. 

6. Make sure the Protect worksheet and contents of locked cells check box is selected, and then click OK. 



            Excel Training Workshop – Feb 16/2017 /Larnaca – TGI FRIDAYS       Page 107 of 111 

F.DATA VALIDATION 
 

You can prohibit the type or range of values that can be inserted in a cell. Or in a range of cells. 

e.g. Not more than 100, or between 0 and 1000, 

e.g. only dates,  

Go to the Data in the Ribbon and select Data Validation -> Data validation 

See the available validations 

 

 

G. Is this cell useful in my calculations? 
 

Find the Precedents and Dependents if a cell so you can safely delete or check if the calculations are 

performed using the correct cells 

 

 

 

Use the Hand Excel Shortcuts.xlsx and the frequencies table 

Check If the percentage is using the right cells for the calculation 
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G. Create a drop-down list 
You can provide a more efficient worksheet by using drop-down lists in cells where people can make a 

Yes or No choice, pick a date from a calendar, or pick from another list you insert. Someone using your 

worksheet clicks an arrow, and then clicks an entry in the list. 

 

 

1. On a new worksheet, type the entries that you want to appear in your drop-down list. The entries 

should be in a single column or row without any blank cells, like this: 

 

Create your drop-down list of entries in single column or row in Excel 
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2. Select all of your entries, right-click, and then click Define Name. 

In the Name box, type a name for your entries, for example, ValidDepts., and then click OK. Be sure your 

name doesn’t have any spaces in it. This name won’t show up in your list, but you need to name it so 

you can link it to your drop-down list. 

 

 

4. Click in the cell in the worksheet where you want the drop-down list. 

5. Click Data >Data Validation. 

 

6. On the Settings tab, in the Allow box, click List. 

7. In the Source box, type and equal sign (=), immediately followed by the name you gave your list in 

step 3. For example, =ValidDepts. 
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8. Check the In-cell dropdown box. 

9. If it’s OK for people to leave the cell empty, check the Ignore blank box. 

10. Click the Input Message tab. 

11. If you want a message to pop up when the cell is clicked, check the Show input message when cell is 

selected box, and type a title and message in the boxes (up to 225 characters). If you don’t want a 

message to show up, clear the check box. 

 

12.Click the Error Alert tab. 

13. Check the Show error alert after invalid data is entered box, pick an option from the Style box, and 

type a title and message. If you don’t want a message to show up, clear the check box. 

 

 

Working with your drop-down list 

After you create your drop-down list, make sure it works the way you want. For example, you might 

want to check to see if the cell is wide enough to show all your entries. 
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DATASETS 
 

The guide has a series of accompanying datasets: 

A direct download can be found here 

 

https://dl.dropboxusercontent.com/u/25474452/excel%20training%20datasets%20-%20fridays.7z

